CHROMiX

Color Settings / Print settings lose track of color profiles

Hi,

This may or my not be related to ColorThink but I started having this problem shortly after I got the latest beta of ColorThink that finally allowed me to disable profiles. I have posted this in a couple of Photoshop forums as well.

I am having a strange problem where Photoshop will not be able to find any of the icc profiles that I have installed in my ~/Library/ColorSync/Profiles directory. They are still visible in Finder, ColorSync Utility and ColorThink.

It has been happening about once every two weeks or so. The only way I seem to be able to fix it is to remove all the profiles from my user Profiles directory, reboot the OS and copy them back.

I was wondering if anyone here had heard of anything like this happening. At first I thought it might be related to using ColorThink to “disable” unused profiles. But the last several times this happened I have not made any changes to any of my Profiles directories.

tks, louie

We had a similar issue, where a couple machines would not recognize any new profiles added to the Colorsync profiles folder. The way we got around it was to trash the cache file - library/caches/com.apple.colorsync.profiles. The next time you assign or convert in Photoshop it gets rebuilt, and there might be a noticeable pause in Photoshop while this is happening.

Bret Hesler

Bret Hesler
Earth.Thebault, Inc.
Parsippany, New Jersey

Post generated from email list

Thanks Bret,

I will try this the next time it happens and I will let you know if it works for my situation. Unfortunately I cannot reproduce the problem it just sort of randomly shows up so I will have to wait and see.

-louie

Hi Herb,

Funny how things go. Its been several days since I had a problem but when I got home, launched PS and my user profiles were AWOL.

I tried removing com.apple.colorsync.profiles file as you suggested but that wasn’t it. However, you got me thinking and after a little poking around I found another folder ~/Library/Caches/Adobe/Color with several files in it. I made an archive of it and then trashed all the files.

Bingo problem fixed!

I did notice that at first there were 4 files contained in the Caches folder and after removing those files and restarting Bridge and PS there are now only 2 files. I am going to send the archive to Adobe and see if they respond and perhaps find something.

Thanks for the tip it got me going in the right direction. I hadn’t thought about color caching. Hopefully this solved my problem. If nothing else at least now I can now quickly reset without having to reboot to make my Color Settings will work.

-louie