"Do Nothing" ICC Profile


We have both Production House and a Fiery RIP for our Canon color copier. It is my understanding that when you profile these devices you always want to disable the existing output profile of the printing device. However, I don’t have the option to completely disable the output profile in either application.

Is there such a thing as “Do Nothing” ICC profile that I could use to in essence turn off the output device profile? I’m thinking that it would simply pass the data straight though?

Any advice would be much appreciated.


What version of Production House & printer do you have? (I’m assuming your Fiery is for the copier)

Onyx does not need to disable the existing media profile in the RIP before profiling - when you start to build a new profile it creates an “empty” media within which you build your calibrations - when you want to print the first of these calibrations the RIPqueue makes you select your new “empty” media before it allows you to print the calibration - thus you do not have an existing profile selected when you are profiling.

If the profile you are referring to is the media name selected on the printer rather than one in the RIP don’t worry - it is not a “profile” as such. All you are doing is telling the printer the type of media loaded so that it can work out what type of ink to use, whether to use the cutter, how much suction it will need on the platen etc etc.

You just need to ensure the paper type you base your profile on in the RIP matches as closely as possible the paper type selected on the printer.

Can’t help with Fiery I’m afraid.

Hope this helps!

Thanks for the suggestions.

We have 6.5 but do not have the profiling bundle I am using Gretag’s eye1 to create my icc profiles.

I follow what your are saying about going through the media manager and it might work using the eye1 to create the profile (I’ll have to look at it closer). But that still leaves me up a creek on my fiery.

No ideas on the “do nothing” icc profile huh?


As long as you can create an icc in your other software you have all you need to build a full media profile in Onyx (assuming you don’t have Ripcentre)

“create” a new Media in Media Manager - give it a name & select the dpi you want to profile by highlighting it on the list to the left.

Then begin to add your calibrations.

Start with the ink restriction - print the swatch & restrict the pure colours where you can’t see or measure any more significant change in density and enter the numbers.

Next do a linearization - print & read with the eye 1.

Then print & assess the ink limit - judge by eye where the black shows no bleeding or artifacting - if you need to cut back into the colours it’s OK but you may limit your gamut.

The last step is to print & read the icc swatch but you can’t do this with your version so you will need to import one built with your Gmac software.

The icc profile is simply a table of figures which represents the difference between the colours your setup produces and the colours that the icc standard requires.

Thus in theory I suppose a “do nothing profile” would have all the figures set to “0”.

I’m guessing this would mean the software assumes your output already matches the icc standard exactly and would not make any changes giving you the same output as if you were not using a profile at all.

When you read the patches you may be given an opportunity to manually change the data - set everything to “0”

I have no idea if this will work - that’s all I can think of!

Select CMYK Simulation : None on the Fiery. This will print CMYK data without an ICC color conversion. Calibration is still applied, which I think you will want. Be sure to calibrate.

Also, once you have created the new output profile (before uploading it to the Fiery) be sure the profile you printed the characterization patches with is set to default. This will associate the same calibration goal to your new profile.

Thanks for the help everyone! With your suggestions, I think that I’m in good shape. Now I just need to get this all written down so I don’t forget.


I’ve tried doing the same thing, setting CMYK simulation to “none” doesn’t work, I’ve tested this by changing the output profile several times while the cmyk simulation is set to none and printing test prints and they all come out with different colors.

I am convinced that the only way to profile this machine correctly is to create a dummy icc profile that makes no changes to the data to be replaced by the new icc profile that is made.