CHROMiX

Runtime Error for Color Think Pro

I run the CTPro on WINXP Pro (sp2) machine. At the beginning, CTPro is OK, after I installed the Coloreyes Display and run the CTPro again, the program just hang and show the following message:-

“Runtime Error 4. Failed Assertion
Press OK To Continue, Press Cancel to Quit
Please Report what caused this error along with the information below:
utility.cpp:1058
Failure Condition:0”

I remove the CTPro and reinstall, the problem still occur. I remove the CED and run the CTPro, the problem dosen’t go away. Is there any solution for the above situation?

B.Rgds
Ricky

Hi Ricky,

I am using XPPro SP2 as well.

I had exactly the same error message, but it was displayed when I was doing something in the programme. (I was using the grapher window to compare some data.) However, I think what I was doing at the time may have been a coincidence and that the failure was related to some ICC version 4.1 profiles in my system/color folder here: C:\WINDOWS\system32\spool\drivers\color.

I have reported my error message to Chromix at [bugfix - at - chromix.com]

If you have used Profile Medic to “repair” an ICC Version 4 profile file’s “internal name” you might find a VERY troublesome “Temp” file in the profiles directory, here: C:\WINDOWS\system32\spool\drivers\color. Filename was “Temp 3284.365” but the numbers vary each time.

You might try removing files with “Temp *.” in their name from C:\WINDOWS\system32\spool\drivers\color.

Note that there was no error in my V4.1 profiles, they just give ColorThink a problem (for now).

Simon

Simon,

Thank you for your hints. I found that temp*** profile in the color directory and I deleted this profile. CTPro up and running again.

I beleived that you’re correct, I’m trying the coloreyes display to make my monitor profile and there have choice for version 4 ICC profile. After that, the CTPro shows the runtime error message.

I’m also wondering if version 2 and 4 ICC profile can be mixed or not. Is this a bug for the CTPro?

Ricky

yes, thanks Simon for the hint about the root of that problem. I’m looking into it’s source…

in the meantime, there should be no problems that I am aware of with ColorThink Pro and v4 profiles. If you find you are having them, please report them to us and we’ll look into it.

regards,

Steve

I think that the issue is probably confined to the internal name / “temp” file as Steve said. In all other respects the V4.1 files seem to be OK.

Simon